Magento Integration 

Overview
This page is a guide on how to install Magento 1 Extension. When integrating Magento with Linnworks Magento 1 Extension will be needed in order to get the integration working and list through Linnworks

Table of Contents

Prerequisites

  • Standard Magento edition (at least 1.7.0.2) downloaded from the Magento official website. Magento modifications are not supported
  • Correct permissions have to be set to allow Magento to write to the following directory: /app/code/local
If you are using Magento version 1.9 or higher, it is required that the following patches are installed: SUPEE-3762, SUPEE-3941 and SUPEE-1533. Patches can be downloaded here.

Detailed Guide

  1. Log in to your Magento backend Admin Area :
    • System > Magento Connect > Magento Connect Manager
  2. Connect again using your credentials 
  3. Install Magento 1 extension (click here to download the file):
    • Click 'Choose file' > Select the file > Click 'Upload'
Please Note. If a previous extension has been installed, this will need to be uninstalled before installing the Magento 1 Extension
  1. Log in to your Magento backend Admin Area:
    • System > Magento Connect > Magento Connect Manager;
  2. Connect again using your credentials 
  3. Uninstall old extension:
    • Find the Extension - 'LinnLiveConnect' > Select Uninstall from the drop-down> Click 'Commit Changes'

To finish with the installation and to make sure your Magento allows to communicate with Linnworks as well as being able to take advantage of our upgraded cloud-based order and inventory synchronisation methodology, please make sure that: 

  • WS-I Compliance is set to Yes
    System > Configuration > Services > Magento Core API
  •  PHP engine configuration has soap.so extension is installed/enabled on your server. Details on how to set this up can found using the following link http://www.php.net/manual/en/soap.setup.php.